spacer.png, 0 kB
  March 23, 2013, 04:23:56

 
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length


Pages: [1] 2 3 ... 10
 1 
 on: February 28, 2013, 06:46:25 
Started by leptserkhan - Last post by leptserkhan
Thanks for the quick reply.  Appreciate it.  Okay, so currently after following your steps I keep receiving a message that urdd is offline.  When I attempt to start it status still says offline.  Then, after a while Status changes to idling.

I can see all the newsgroups listed under admin/usenet. I have clicked the button and it has turned from red to green.  It still remains "Idling" under status.

Setting/Newsgroups shows nothing.  Empty.  Nada.

If I go to Admin/tasks I only see cleaning database 100%.

Under admin/dashboard there is no method to start anything.  It's all just a bunch of statistics.

One important question: must I have login credentials for all those usenet servers in order for all this to work?  My understanding is that not all of them require an account.

 2 
 General Category / Technical Problems / Re: completely lost on how to use
 on: February 27, 2013, 19:33:39 
Started by leptserkhan - Last post by spearhead
First you should enable one or more usenet server by clicking in admin/usenet servers on one of the red button to the left and enable indexing for one of them. You can press the edit button right to set a username/password if needed. If your newsserver is not there yet, you can add one under actions/add new. (please post/pm the name, hostname and port)

A group update should run automatically, if the above is successful. Otherwise check admin /tasks and kill the groups command, then re-run it manually under admin/dashboard. The grouplist shou/ld appear under settings/newsgroups. From there you can subscribe one or more for indexing. The reslts are shown under supply/groups. Alternatively you can start using spots under supply; click actions/update to update them.

I think I oughta update the manual a bit or two some time.

Let me know if you run in any trouble.

 3 
 General Category / Technical Problems / completely lost on how to use
 on: February 26, 2013, 21:16:31 
Started by leptserkhan - Last post by leptserkhan
Ok so everything installed correctly.  Now the manual states:

"If there are no newsgroups found go to the admin panel and click "Update newsgroup list".

So there is no option under the admin link at the top of the URD page to click on "update newsgroup list"

Under Actions there is a link to Update Newsgroup List, which I click and I see a bright yellow message that state "update newsgroup started" then it goes away and I still see nothing.

More Information:

Under Status it states Idling.

Under Admin | Newsgroup Servers I do see a list of servers -- so now what to do with those?

Under Admin | Configuration everything looks normal.

Upper left corner there is a green button that when hovered states: click to turn off urrd.

Please if some could explain exactly what is someone supposed to do once they get logged in that would be appreciated.


 4 
 on: January 22, 2013, 00:33:04 
Started by lbeckm3 - Last post by lbeckm3
Great!  That worked - thank you!  I'm on to installation screens now.   Grin

I did have problems using apt-get later on - to fix it it suggests doing;

Code:
$sudo apt-get install -f

which it then wants to remove URD.  To fix this I edited the file;

/var/lib/dpkg/status

and then searched and removed yyencode from the "Depends" list so it now looks like this;

Code:
Package: urd
Status: install ok installed
Priority: extra
Section: news
Installed-Size: 6907
Maintainer: Gavin Spearhead
Architecture: all
Version: 1.6.1-1
Depends: apache2, php5, mysql-server, php5-cli, php5-mysql, unrar, par2, php5-xmlrpc, php5-curl, coreutils, procps, php5-gmp, php5-gd
Recommends: arj, p7zip-full, unace-nonfree, trickle, unzip, tar, p7zip, cfv
Suggests: vnstat
Description: Web based binary download
 URD is a program to download binaries from usenet (newsgroups) via a web based interface. It's written entirely in PHP, besides making use of a few external programs to do some of the CPU intensive work. It stores all the information it needs in a generic database (like MySQL, or PostGreSQL). Articles are aggregated into sets of files that belong together. Downloading requires only a few clicks. Optionally, an NZB file can be created. When the download is finished it can automatically verify the par2 or sfv files and decompress the results. In the background URD uses a download program called URDD or the URD Daemon. This daemon handles nearly all of the activity with respect to the newsgroups, the sets and the downloads.
Homepage: http://www.urdland.com

After that, apt seems happy again.  Hope this helps someone. 

 5 
 General Category / Technical Problems / Re: yydecode pathing issue?
 on: January 21, 2013, 22:58:42 
Started by lbeckm3 - Last post by spearhead
the error you get is a package error, it doesn't actually look for files afaik.
You can probably use this option for dpkg:
--ignore-depends=yydecode

alternatively you can get .deb from one of the mirrors of getdeb for 12.04

 6 
 General Category / Technical Problems / [Solved] yydecode pathing issue?
 on: January 21, 2013, 19:48:14 
Started by lbeckm3 - Last post by lbeckm3
Ok, I'm attempting to put URD on an Ubuntu 12.04 server I'm building.  I had it up and running fine on my desktop using standard 12.04 for quite some time.  However, it appears the deb file for yydecode is no longer working and I cannot install it that way.  I did install it from source and everything seems fine (it installed it to /usr/local/bin/yydecode), however when I try and install URD I get the following;

Code:
# dpkg -i urd_1.6.1-1_all.deb
Selecting previously unselected package urd.
(Reading database ... 60542 files and directories currently installed.)
Unpacking urd (from urd_1.6.1-1_all.deb) ...
dpkg: dependency problems prevent configuration of urd:
 urd depends on yydecode; however:
  Package yydecode is not installed.
dpkg: error processing urd (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 urd

I've added symlinks ALL over the place /usr/bin /usr/sbin etc etc. but no joy - still wont see it.  What path does URD look for yydecode?  I've even just copied the binary over without symlinks to several directories just in case it didn't like symlinks but still wont see it.

Thanks!

-Lyle

 7 
 on: December 15, 2012, 01:23:20 
Started by greencopper - Last post by spearhead
Well it's a two step process after the update function that gets the articles from the newsgroup server.
First articles are grouped to binaries
Then binaries are grouped into sets
Essentially it looks for specific similarities in the subject to combine them.

If it slow the first thing to do is look at the database settings. Running mysqltuner.pl might help to finetune this. Mostly index buffers are the key performance aspect here, which means the more memory the better. By default mysql is rather conservative in memory usage. CPU isn't that important really.
wget mysqltuner.pl

The code is quite straight forward, but I've been running many algorithms in the past but setting on the current one as it seems to be the fastest on average.

one thing to look at is the spam filter, which will throw a way a huge set of data. For groups like  a.b.x264  you may set it to 1M or larger even 100M but then you might miss some sets that are still largely incomplete.

 8 
 on: December 15, 2012, 01:16:30 
Started by greencopper - Last post by spearhead
I added this to the comments field for now; visible under admin/tasks

 9 
 General Category / General Discussion / Generating sets, how does it work?
 on: December 14, 2012, 04:57:03 
Started by greencopper - Last post by greencopper
I haven't had a change to look at the code yet, I only discovered URD a couple of days ago and have been running some tests, but how does the generating sets work?

I'm asking because this seems to be the most tasking proces of URD. So far I have only testet on "older" hardware, a P4 2.6 Ghz dual cpu.

Generating sets on the group a.b.x264 with an expire on just 1 day 2.7M in the tasks display showed an ETA of 3 days and some 15 hours.

However, doing the same for the group a.b.town also with 1 day, but with 5.4M takes about 3 hours.

What exactly are the code doing?

Best regards!

 10 
 on: December 13, 2012, 19:30:18 
Started by greencopper - Last post by greencopper
Thanks! I'll monitor the changes.

Pages: [1] 2 3 ... 10
Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC
Amigri by Fakdordes
spacer.png, 0 kB
spacer.png, 0 kB
spacer.png, 0 kB